Discussion:
[HANGOUT] Topics for 7/25/17
(too old to reply)
Arina Yelchiyeva
2017-07-24 16:46:44 UTC
Permalink
Raw Message
Hi all,

We'll have the hangout tomorrow at the usual time [1]. Any topics to be
discussed?

[1] https://drill.apache.org/community-resources/

Kind regards
Arina
Padma Penumarthy
2017-07-25 04:41:43 UTC
Permalink
Raw Message
I have a topic to discuss. Lot of folks on the user mailing list raised
the issue of not being able to access all S3 regions using Drill.
We need hadoop version 2.8 or higher to be able to connect to
regions which support only Version 4 signature.
I tried with 2.8.1, which just got released and it works i.e. I am able to
connect to both old and new regions (by specifying the endpoint in the config).
There are some failures in unit tests, which can be fixed.

Fixing S3 connectivity issues is important.
However, the hadoop release notes for 2.8.1 (and 2.8.0 as well) say the following:
"Please note that 2.8.x release line continues to be not yet ready for production use”.

So, should we or not move to 2.8.1 ?

Thanks,
Padma


On Jul 24, 2017, at 9:46 AM, Arina Yelchiyeva <***@gmail.com<mailto:***@gmail.com>> wrote:

Hi all,

We'll have the hangout tomorrow at the usual time [1]. Any topics to be
discussed?

[1] https://drill.apache.org/community-resources/

Kind regards
Arina
Arina Yelchiyeva
2017-07-25 17:04:46 UTC
Permalink
Raw Message
Hangouts is starting now...
Post by Padma Penumarthy
I have a topic to discuss. Lot of folks on the user mailing list raised
the issue of not being able to access all S3 regions using Drill.
We need hadoop version 2.8 or higher to be able to connect to
regions which support only Version 4 signature.
I tried with 2.8.1, which just got released and it works i.e. I am able to
connect to both old and new regions (by specifying the endpoint in the config).
There are some failures in unit tests, which can be fixed.
Fixing S3 connectivity issues is important.
"Please note that 2.8.x release line continues to be not yet ready for
production use”.
So, should we or not move to 2.8.1 ?
Thanks,
Padma
Hi all,
We'll have the hangout tomorrow at the usual time [1]. Any topics to be
discussed?
[1] https://drill.apache.org/community-resources/
Kind regards
Arina
Arina Yelchiyeva
2017-07-25 17:35:52 UTC
Permalink
Raw Message
Meeting minutes 25 July 2017:

Attendees:
Rob, Vova, Sorabh, Pritesh, Paul, Aman, Padma, Jyothsna, Sindhuri.

Two topics were discussed.
1. Release candidate for 1.11.0.
Everybody is encouraged to test the release candidate and vote.
Aman asked about the release candidate performance testing.
Asked Kunal via email and he confirmed that performance testing is in
progress.

2. Upgrade to hadoop version 2.8.
Padma was looking into S3 connectivity issues and found out that switching
to Hadoop version 2.8.1 will solve these problems.
However, the hadoop release notes for 2.8.1 (and 2.8.0 as well) say the
following:
"Please note that 2.8.x release line continues to be not yet ready for
production use”.
Was decided to wait till the next Hadoop stable version release (hopefully
before Drill 1.12.0 release)
and for now document that users may switch to 2.8.1 themselves.


Thank you all for attending the hangout today.

Kind regards
Arina

On Tue, Jul 25, 2017 at 8:04 PM, Arina Yelchiyeva <
Post by Arina Yelchiyeva
Hangouts is starting now...
Post by Padma Penumarthy
I have a topic to discuss. Lot of folks on the user mailing list raised
the issue of not being able to access all S3 regions using Drill.
We need hadoop version 2.8 or higher to be able to connect to
regions which support only Version 4 signature.
I tried with 2.8.1, which just got released and it works i.e. I am able to
connect to both old and new regions (by specifying the endpoint in the config).
There are some failures in unit tests, which can be fixed.
Fixing S3 connectivity issues is important.
"Please note that 2.8.x release line continues to be not yet ready for
production use”.
So, should we or not move to 2.8.1 ?
Thanks,
Padma
Hi all,
We'll have the hangout tomorrow at the usual time [1]. Any topics to be
discussed?
[1] https://drill.apache.org/community-resources/
Kind regards
Arina
yuliya Feldman
2017-07-26 06:39:13 UTC
Permalink
Raw Message
Sorry for the late chime in.Just a note - regarding s3 - even after upgrade to hadoop 2.8.x you may need to separately update versions of aws, as one provided with the upgrade is not supporting all the newly added regions.
Thanks,Yuliya

From: Arina Yelchiyeva <***@gmail.com>
To: ***@drill.apache.org
Cc: user <***@drill.apache.org>
Sent: Tuesday, July 25, 2017 10:35 AM
Subject: Re: [HANGOUT] Topics for 7/25/17

Meeting minutes 25 July 2017:

Attendees:
Rob, Vova, Sorabh, Pritesh, Paul, Aman, Padma, Jyothsna, Sindhuri.

Two topics were discussed.
1. Release candidate for 1.11.0.
Everybody is encouraged to test the release candidate and vote.
Aman asked about the release candidate performance testing.
Asked Kunal via email and he confirmed that performance testing is in
progress.

2. Upgrade to hadoop version 2.8.
Padma was looking into S3 connectivity issues and found out that switching
to Hadoop version 2.8.1 will solve these problems.
However, the hadoop release notes for 2.8.1 (and 2.8.0 as well) say the
following:
"Please note that 2.8.x release line continues to be not yet ready for
production use”.
Was decided to wait till the next Hadoop stable version release (hopefully
before Drill 1.12.0 release)
and for now document that users may switch to 2.8.1 themselves.


Thank you all for attending the hangout today.

Kind regards
Arina

On Tue, Jul 25, 2017 at 8:04 PM, Arina Yelchiyeva <
Post by Arina Yelchiyeva
Hangouts is starting now...
Post by Padma Penumarthy
I have a topic to discuss. Lot of folks on the user mailing list raised
the issue of not being able to access all S3 regions using Drill.
We need hadoop version 2.8 or higher to be able to connect to
regions which support only Version 4 signature.
I tried with 2.8.1, which just got released and it works i.e. I am able to
connect to both old and new regions (by specifying the endpoint in the config).
There are some failures in unit tests, which can be fixed.
Fixing S3 connectivity issues is important.
"Please note that 2.8.x release line continues to be not yet ready for
production use”.
So, should we or not move to 2.8.1 ?
Thanks,
Padma
Hi all,
We'll have the hangout tomorrow at the usual time [1]. Any topics to be
discussed?
[1] https://drill.apache.org/community-resources/
Kind regards
Arina
Loading...